Scheduled posts to X/Twitter are failing to publish

Incident Report for Later

Resolved

This incident has been resolved.
Posted Mar 28, 2025 - 13:29 PDT

Monitoring

Publishing to X/Twitter as expected looks to have been restored. Our teams are monitoring to ensure the fix implemented by X has fully resolved this issue.
Posted Mar 28, 2025 - 13:06 PDT

Investigating

We are aware of an issue impacting X/Twitter's API that is causing posts scheduled via Later to fail when trying to publish. We are actively monitoring the situation for further updates.
Posted Mar 28, 2025 - 12:32 PDT
This incident affected: Social Networks (Twitter).